Speed problem

tim.conway at philips.com tim.conway at philips.com
Mon Nov 11 20:13:01 EST 2002

I don't have a system with ssh available to check with (believe it or not, 
it's not approved for our network), but i think the sshd_config or 
ssh_config might be able to specify using compression as a default.  Is 
ssh on the sending side, perchance, using a lot of CPU?  I don't know of 
any cpu that can create anything close to a GB/sec compressed _input_, 
much less output.
I don't even remember if you can turn the compression off if it IS 

Barring that, If you aren't concerned about somebody sniffing the content 
you're syncing, perhaps you could use the internal transport?  If you can 
protect your ssh private keys, you can protect your rsync password-file as 
well.  This also has the advantage of cutting down on context switches, as 
one process is doing both the sync stream AND the communication.

Tim Conway 
conway.tim at spilihp.com reorder name and reverse domain 
303.682.4917 office, 303.921.0301 cell 
Philips Semiconductor - Longmont TC 
1880 Industrial Circle, Suite D 
Longmont, CO 80501 
Available via SameTime Connect within Philips, caesupport2 on AIM 
"There are some who call me.... Tim?" 

uwp at dicke-aersche.de
Sent by: rsync-admin at lists.samba.org
11/11/02 08:30 AM
Please respond to uwp

        To:     rsync at lists.samba.org
        cc:     (bcc: Tim Conway/LMT/SC/PHILIPS)
        Subject:        Speed problem

Mermgfurt !

I have some problem with syncing two machines which are connected
over a Gigabit-connection. I'm trying to use rsync with ssh because of
the authorisation mechanisms (keys). It starts quite ok with 18 MB/s
(this small speed may have something to do with our internal net)
and falls down to 400 KB/s (!!!). This happens over a long period
because those files I want to copy are very big (upto 70 GB per file).
Even though I tried to increase the blocking size the speed just goes
down and won't go up again. In fact it really writes 18 MB/s, it's not
just a problem of -partial or something similar. Ok, I haven't tried
it without ssh yet, but it really looks very strange.
The version is the rsync 2.5.6cvs version from debian-unstable.

Thanks for any help !


Udo Wolter                      |  /"\
email:    uwp at dicke-aersche.de  |  \ / ASCII RIBBON CAMPAIGN
www:      www.dicke-aersche.de  |   X    AGAINST HTML MAIL
dark:    heaven at lutz-ziffer.de  |  / \

To unsubscribe or change options: http://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.tuxedo.org/~esr/faqs/smart-questions.html

More information about the rsync mailing list