rsync 2.5.5, HPUX, getting unexplained error at main.c(578)

Charles F. Fisher chuck at
Wed May 29 10:28:01 EST 2002

I compiled rsync-2.5.5 on HPUX 11.11, using the +DA2.0W and +O3 options.

invoking a simple rsync to transfer a file works (I ran a diff on the file,
no changes) e.g:

sdx1 214: ./rsync --rsh='/usr/bin/ssh -x' --rsync-path=/usr/local/src/rsync-2.5.5/rsync /scratch/chuck/tmp.test sdx2:/scratch/chuck

However, adding the -a option yields an unexplained error:
(In all of the following  cases the file is transferred successfully; the 
problem was originally noted transferring a directory, but the examples were
simplified since a single file transfer will also show the problem.)

sdx1 213: ./rsync --rsh='/usr/bin/ssh -x' --rsync-path=/usr/local/src/rsync-2.5.5/rsync -a /scratch/chuck/tmp.test sdx2:/scratch/chuck
rsync error: unexplained error (code 48) at main.c(578)

I removed the file from the target machine and tried again - it gives a
different unexplained error at the same location:

sdx1 215: !213
./rsync --rsh='/usr/bin/ssh -x' --rsync-path=/usr/local/src/rsync-2.5.5/rsync -a /scratch/chuck/tmp.test sdx2:/scratch/chuck
rsync error: unexplained error (code 151) at main.c(578)

Transferring the file back by specifying the remote machine as the source 
works without getting an error:

sdx1 216: ./rsync --rsh='/usr/bin/ssh -x' --rsync-path=/usr/local/src/rsync-2.5.5/rsync -a sdx2:/scratch/chuck/tmp.test /scratch/chuck/tmp.testa

Any suggestions about what the problem could be and how to fix it?

More information about the rsync mailing list