rsync 2.5.5, HPUX, getting unexplained error at main.c(578)

Allen D. Winter winterz at
Wed May 29 14:51:01 EST 2002

Once upon a time I threw printfs all over the source looking to track down
the cause of this problem.  Seemingly a random error code is generated
each time rsync is run *succesfully* on HPUX.

I finally found that in the wait_process() function in main.c, the status 
value returned from WEXITSTATUS() was apparently returning
the pid of the child instead of the exit status of the child... or something
like that.

I've learned to ignore the error codes and live with it.
Love to see this fixed.

On Wednesday 29 May 2002 01:24 pm, Charles F. Fisher wrote:
> I compiled rsync-2.5.5 on HPUX 11.11, using the +DA2.0W and +O3 options.
> invoking a simple rsync to transfer a file works (I ran a diff on the file,
> no changes) e.g:
> sdx1 214: ./rsync --rsh='/usr/bin/ssh -x'
> --rsync-path=/usr/local/src/rsync-2.5.5/rsync /scratch/chuck/tmp.test
> sdx2:/scratch/chuck
> However, adding the -a option yields an unexplained error:
> (In all of the following  cases the file is transferred successfully; the
> problem was originally noted transferring a directory, but the examples
> were simplified since a single file transfer will also show the problem.)
> sdx1 213: ./rsync --rsh='/usr/bin/ssh -x'
> --rsync-path=/usr/local/src/rsync-2.5.5/rsync -a /scratch/chuck/tmp.test
> sdx2:/scratch/chuck rsync error: unexplained error (code 48) at main.c(578)
> I removed the file from the target machine and tried again - it gives a
> different unexplained error at the same location:
> sdx1 215: !213
> ./rsync --rsh='/usr/bin/ssh -x'
> --rsync-path=/usr/local/src/rsync-2.5.5/rsync -a /scratch/chuck/tmp.test
> sdx2:/scratch/chuck rsync error: unexplained error (code 151) at
> main.c(578)
> Transferring the file back by specifying the remote machine as the source
> works without getting an error:
> sdx1 216: ./rsync --rsh='/usr/bin/ssh -x'
> --rsync-path=/usr/local/src/rsync-2.5.5/rsync -a
> sdx2:/scratch/chuck/tmp.test /scratch/chuck/tmp.testa
> Any suggestions about what the problem could be and how to fix it?

More information about the rsync mailing list