SCRATCH update wrong date, soft links, Debian stable, -L, ...

tim.conway at tim.conway at
Mon May 20 09:59:24 EST 2002

Maybe it was the other time.  newer goes by mtime, as does ls, by default. 
 I think rsync checks ctime too.

Tim Conway
tim.conway at
Philips Semiconductor - Longmont TC
1880 Industrial Circle, Suite D
Longmont, CO 80501
Available via SameTime Connect within Philips, n9hmg on AIM
perl -e 'print pack(nnnnnnnnnnnn, 
".\n" '
"There are some who call me.... Tim?"

"John D. Hendrickson" <jdh at>
Sent by: rsync-admin at
05/18/2002 10:29 PM

        To:     rsync at
        cc:     (bcc: Tim Conway/LMT/SC/PHILIPS)
        Subject:        SCRATCH update wrong date, soft links, Debian stable, -L, ...


scratch the issue

I used touch on the file and now it works (even though it shouldn't have
made a difference).  In short - maybe its not [purely anyway] rsync

(From last post)

(Though 'newer' and 'stat' had already clearly showed it to be newer,
and though I had saved it to be sure it had a recent date - I tried
touch anyway.  Still - newer said it was newer and rsync didn't - but in
that case touch shouldn't have changed the condition.  So maybe its an
nfs fluke?  Who knows...)

To unsubscribe or change options:
Before posting, read:

More information about the rsync mailing list