Problems getting rsync working...

Brad bradb at
Wed May 15 17:30:03 EST 2002

I am having some problems getting rsync working.

No files get copied, although the server HD light DOES come on for about a 
second when I run the client rsync command.

The /etc/rsyncd.conf on the server:
uid = root
gid = root
log = /var/log/rsync.log
read only = no

# Email data files from /var/spool/mail on Proxy (
path = /home/databackup/

 4 drwxrwxrwx    3 root     root         4096 May 15 14:34 databackup

The /etc/hosts file on the client:           StorageServer

The /etc/services file on the server:

[root at StorageServer etc]# grep rsync /etc/services
rsync           873/tcp                         # rsync
rsync           873/udp                         # rsync

The command which is run on the client:
rsync -avt /var/spool/mail StorageServer::email
I have also tried /tmp but it is still the same.

I am running the command as root, and the root passwords on both systems are 
the same.

There is no logfile. I have tried to create one and chmoded it to 777, but 
nothing gets written in there. I have also tried changing the logfile 
location to /tmp but it still doesn't get created.

The client is running rsync-2.4.4-1 on RedHat 7.0 and the server is running 
rsync-2.5.4-2 on Redhat 7.3. I have tried to upgrade rsync on the 7.0 PC but 
it requires a new version of glibc, which I cannot install due to lots of 
dependancy issues.

Can anyone shed any light on this?


More information about the rsync mailing list