Compiling on a Cobalt RaQ1

Martin Pool mbp at
Tue Mar 12 10:27:29 EST 2002

On 11 Mar 2002, Jurrie Overgoor <jurr at> wrote:
> 'lo,
> After a long search through the archives I got my awnser. It seams that the
> glibc package that comes with RH5.2 (with the Cobalt RaQ1 is based on) is
> broken. I need to upgrade...
> Now the sh*tty part:
> To compile rsync 2.5.x I need to upgrade glibc
> To upgrade glibc I need to upgrade gcc and gmake
> I tried to compile gcc and I got errors...
> Then I got a bit frustrated, and I tried an old version (rsync 2.4.6). That
> worked ok, so I'll use that one. Are there any significant changes in 2.5.2
> opposed to 2.4.6?

There are some bugs fixed in 2.5 -- most importantly, one that
sometimes causes rsync-over-ssh to hang.  If they're not bugging you,
it would be OK to stay on 2.4.

It ought to be possible to fix 2.5 to work on RH5, but I haven't got
around to it yet.  If you want, you could start by looking at whether
the builtin getaddrinfo is used or not.

Altneratively you could cross-compile a static version of rsync using
the MIPS gcc on some other machine.


More information about the rsync mailing list