rsync hangs on w2k server running cygwin

Stirling Olson seo at
Thu Jul 25 15:29:01 EST 2002


I'm having trouble getting a clean run of rsync on a w2k server running
cygwin.  Basically, it appears that the commands are running to completion
(i.e. files are being copied) but the command does not return to a command
prompt (or continue to the next command when run via a script).

The machine is a w2k server completely up-to-date with all service packs
(SP2) and updates.  I have just installed cygwin (1.3.12-2) and rsync
(2.5.5-1) from the cygwin setup.exe program.  The server has been rebooted
and I have even tried re-installing the cygwin packages (and again
rebooting) to make sure.  At first I thought the hanging problem was due to
using SSH but when I tried rsync simply copying local files (without SSH), I
got the same behavior.  I've searched google and the rsync mailing list and
can't seem to find anything that addresses this issue.  FWIW, I'm logged on
to the w2k server with administrator's rights.

Here is a log of the behavior:

loki at SULTANA ~
$ rsync -vvr ~/test1/ ~/test2
building file list ...
expand file_list to 4000 bytes, did move
hereisafile is uptodate
total: matches=0  tag_hits=0  false_alarms=0 data=0

NOTE: from here it just hangs.  The only way I can get the command prompt
back is to ctrl-c.  I have let it sit for many minutes without any luck.
Also, as you can see from below, the directory and files are very small so
it shouldn't take long.

loki at SULTANA ~
$ ls -l
total 2
drwxr-xr-x    2 loki     Domain U        0 Jul 25 17:57 test1
drwxr-xr-x    2 loki     Domain U        0 Jul 25 17:57 test2

loki at SULTANA ~
$ ls -l test1
total 1
-rw-r--r--    1 loki     Domain U       21 Jul 25 17:57 hereisafile

loki at SULTANA ~
$ ls -l test2
total 1
-rw-r--r--    1 loki     Domain U       21 Jul 25 17:57 hereisafile

Anyone have any ideas or have a similar problem?  I'm happy to provide more
information about the setup or command specifics.


More information about the rsync mailing list