rsync: error writing NNNN unbuffered bytes - exiting:Connection reset by peer -> NIC driver problem!

Bill Geddes bill_geddes at
Thu Jul 18 15:53:01 EST 2002

I was seeing rsync errors which caused my system installations to fail
repeatedly and absolutely.  See the error I reported to this mailing
list back in June in the Forwarded Message below.

When I replaced my NIC cards (realtec chip, 8139too driver) with Linksys
cards (and Dec Tulip driver for linux) the problem ceased, rsync worked
like it should, and does so repeatedly.

My suggestion would be to keep and publish on the Rsync website a list
of linux network hardware and driver combos that are: 1. Know Good, 2,
Known to have problems.  Put Realtec NICs with the 8139too driver on the
"Known to have problems" list.

-----Forwarded Message-----

From: Bill Geddes <bill_geddes at>
To: rsync at
Subject: rsync: error writing NNNN unbuffered bytes - exiting:Connection reset by peer
Date: 13 Jun 2002 09:38:56 -0600

Has anyone figured out what is happening with this error?  There are
many reports of this, but the advise seems to fall short - ie. make sure
you are using rsync 2.5.n, make sure the target disk is not full.

I have used rsync 2.5.[1,2,4,5] on my rsync server, and I get the same
results.  The target disk I am working with never gets more than 2% full
when the rsync client and server quit talking to each other.  I'm using
a 2.4.18 Linux kernel(both), ext2 filesystems (both).  Networking is
100Mbit, each NIC card is Realtec 8139too driver compatible.

I've tried adding the '--bwlimit=NNNN' and '--blocking-io' options when
invoking the client rsync, but neither affects the result.

Suggestions on how to proceed would be greatly appreciated.

To unsubscribe or change options:
Before posting, read:
Bill Geddes                            
  bill_geddes at

"I had a fortune cookie the other day and it said: 'Outlook not
so good'. I said: 'Sure, but Microsoft ships it anyway'."

More information about the rsync mailing list