Large File Support on AIX 4.3.3

Scott Powell Scott.Powell at
Thu Aug 1 11:51:01 EST 2002

I've been trying to get rsync to work on AIX 4.3.3 with files > 2GB. I've looked through the archives and saw reference to this, etc. on HPUX but have not been able to come across a solution for AIX. I've tried compiling with the following flags without luck:


There error I'm getting is as follows (when hitting the 2GB limit):

	rsync: error writing 32768 unbuffered bytes - exiting: Broken pipe
	rsync error: error in rsync protocol data stream (code 12) at io.c(463)

When I run ./configure I see these lines pertaining to large file support:

	checking for broken largefile support... no
	checking for special C compiler options needed for large files... no
	checking for _FILE_OFFSET_BITS value needed for large files... no
	checking for _LARGE_FILES value needed for large files... 1
My filesystems are large file enabled and fsize is set to -1 in /etc/security/limits. Does anyone have any suggestions on getting this to work on AIX 4.3.3? The rsync version is (2.5.5).

$ rsync
rsync  version 2.5.5  protocol version 26
Copyright (C) 1996-2002 by Andrew Tridgell and others
Capabilities: 64-bit files, socketpairs, hard links, symlinks, batchfiles,
              no IPv6, 32-bit system inums, 64-bit internal inums


More information about the rsync mailing list