[clug] IPv6 config on Jessie not working

Bob Edwards bob at cs.anu.edu.au
Fri Jan 20 05:21:08 UTC 2017

On 18/01/17 12:42, Bob Edwards wrote:
> Giving up trying the mess that is Google searching and going for the
> tried and true widsom of the CLUG list!

Thanks to those who wrote to me directly with some tips etc. I have now
located the problem and fixed it.

Turns out that I was getting error messages in /var/log/daemon, I just
managed to have not noticed them earlier... (wrong side of 50...)

The error was in a mis-written shell script from the ifupdown-extra
package (not sure why I have that installed on this server...)

The bug is described in:
(yes, Ubuntu to the rescue...).

Each network interface config was failing, but after it had already
allocated (the first) IP address for that interface. Hence my

Fixed the /etc/network/if-up.d/00check-network-cable script (as per
the patch at the above URL), rebooted and all is good with the world
again... (for a little while, anyway).


Bob Edwards.

> I have a server with multiple interfaces, some with both IPv4 and IPv6,
> running Debian Jessie.
> My /etc/network/interfaces file has many stanzas, but includes
> something like:
> auto eth0.1119
> iface eth0.1119 inet6 static
>         address a:b:c:f::g
>         netmask 64
>         up echo 1 > /proc/sys/net/ipv6/conf/eth0.1119/forwarding
> # The primary network interface
> auto eth1
> iface eth1 inet static
>         address w.x.y.z
>         netmask
>         network w.x.y.0
>         broadcast w.x.y.255
>         gateway w.x.y.1
>         up /etc/network/rc.firewall
> iface eth1 inet6 static
>         address a:b:c:d::e
>         netmask 64
>         gateway a:b:c:d::1
>         up echo 1 > /proc/sys/net/ipv6/conf/eth1/forwarding
> (note that eth0.1119 does not have an IPv4/inet stanza, ie. the IPv6/
> inet6 stanza is the only one for that interface).
> The interfaces with only an IPv6 stanza (such as eth0.1119) come up
> correctly with an IPv6 address at system boot, and the IPv4/inet
> address is assigned correctly for eth1, but no IPv6/inet6 address is
> assigned for eth1.
> There is another interface with two stanzas, first one for IPv4 and
> second for IPv6, and the IPv6 address is not being assigned for that
> interface either.
> This all used to work correctly, but seems to have stopped, maybe
> as long ago as the upgrade from Wheezy to Jessie (I think I may have
> manually set the IPv6 addresses some time ago and not got back to
> investigating why it wasn't set automatically).
> Anyone got any clues/suggestions as to what I am doing wrong here?
> Any ideas how I can enable some logging to see if the system might
> want to tell me why it isn't assigning the IPv6 address?
> cheers,
> Bob Edwards.

More information about the linux mailing list