[clug] ntfs-3g anyone?

Owen Cook owen.cook at gmx.com
Wed Jun 22 03:32:37 UTC 2016

> I am having issues with a 2.5" USB disk.

> I searched and found no solution. Anyone using ntfs-3g?
> 2)
> Another issue, may be related, is that on f19 (where the mount is visible) I get bad data regularly.
> This is a new 4TB disk which I want to use for archival storage. Naturally I run checksum on the
> files and I am getting many files delivering bad checksums. Re-running fails a different set of files.
> There are no errors logged that I could find.
> I should mention that this disk was formatted and written to on Windows 8.1, and as such I expect the
> data on it to be in good shape. Furthermore, a failed checksum will come good next time I try the same
> file.

FWIW, I received a 500MB 2.5" ntfs formatted disk with 5 GB of data.

An attempt to place another 20GB via a USB port from a Fedora 23 installation failed.

I took the disk to a Win7 machine and it had no problem transferring the data.

Mystery. So later I tried formatting the disk to ntfs via fdisk and again an attempted 20 GB transfer failed, just locked up everything.
Then I formatted it with ntfs via Win7 and on Windows, had no problem transferring 20+GB
Test a transfer from a Ubuntu machine also failed. 

I gave up as I had achieved what I wanted to achieve, and concluded, rightly or wrongly that the ntfs algorithm is different between the Linux and Widows systems.


More information about the linux mailing list