[clug] PLEASE HELP! I have angered the network printing gods!

Rodney Peters rodneyp at iinet.net.au
Thu Jul 2 20:04:41 MDT 2015

I've been using two Brother multi-functions (laser + inkjet) for several years 
without major issues as *wired* network devices.  But I gave up last year when 
asked to install a mono laser as Wifi.  Seemed to me that there was a classic 
"catch 22" - you must install the Wifi setup via another mechanism -  wired 
network/USB/control panel - then change the config to Wifi (the printer can't 
do both Wifi & wired simultaneously)  Too bad if you have the Wifi config 
wrong because then get into protracted loop of troubleshooting via USB/control 
panel and I could not get any useful result via either.

I find that the most reliable way to install Brother drivers is at good old 
CLI.  Suggest you follow the directions at:


I find it best to use the "driver installer tool" - otherwise the queue 
defaults to USB - and the job hangs around forever if sent via other media.  
The tool does require that you specify a DeviceURI for a network printer, 
which for WiFi probably requires pre-setting same via the panel.

BTW, if you must uninstall the drivers then it is most reliably done via 
Brother's CLI tool - otherwise configs get left hanging around.


On Fri, 3 Jul 2015 10:39:19 David C wrote:
> I have a nearly identical setup and it defeated me.
> Mine is Mint17.
> I know that removing / reinstalling CUPS and all Brother packages doesn't
> help.
> What do you have in cups and system logs?
>  On 3 Jul 2015 10:35, "Jessica Fryer" <jessicanumber at gmail.com> wrote:
> > Hi everyone I'm desperate for help. I've tried like two things and I'm all
> > out of ideas.
> > 
> > I've got a HP Pavilion 15 running Ubuntu 12.04
> > I've got the crappy wireless router my ISP sent me since the old one
> > needed
> > replacing anyway.
> > I've got a Brother HL-3170CDW from OfficeWorks.
> > 
> > Everything was going swimmingly. Colour, duplex, a little trouble with
> > really unusual fonts but I've gone through a few hundred pages, mostly
> > b&w,
> > in the few months I've had it.
> > 
> > Yesterday I had two jobs. Print a few info leaflets for a demonstration
> > and
> > print a menu to make comments.
> > 
> > I ran out of each colour at the same time, replaced them all, the job
> > finished (with some errors toward the end that usually occur when I try to
> > send through weird pictures or fonts, but still, they printed) and then
> > 
> > I've re-installed the printer, power cycled the wireless, power cycled the
> > printer and then re-connected it to the network from scratch (re-entered
> > the password and everything), deleted the printer on the laptop and then
> > re-found it and re-installed it, installed necessary updates, power cycled
> > the laptop. The same test page has been in the queue for 15 hours.
> > 
> > I'm using a driver called HL-3170CDW CUPS that came up during the wizard.
> > The printer status message says deep sleep but the data light is on.
> > 
> > Any ideas or places I can look for advice?
> > 
> > Jessica
> > --
> > linux mailing list
> > linux at lists.samba.org
> > https://lists.samba.org/mailman/listinfo/linux

More information about the linux mailing list