[clug] Problem getting a working IPv6 connection

Russell Weatherburn russell at oxyoss.net
Fri Feb 1 23:04:14 MST 2013

Hi there,

It's not something silly like forwarding not being turned on via the 
server?  I know that I kept getting that wrong with IPv4 when I had my 
system in bridged mode....

$ cat /proc/sys/net/ipv6/conf/all/forwarding

(replace the "all" above with the specific interface, I assume - I have 
to admit that I have not delved much into IPv6 as yet)



On 1/02/2013 12:50 PM, Simon Fowler wrote:
> I'm trying to get a dual stack setup working here with my home
> network, connected via Internode. I've got an older model modem that
> doesn't support IPv6 itself, so instead I'm bridging the connection
> through to my server (Debian, currently testing) and running
> everything through that. This setup works very nicely with IPv4, but
> when it comes to v6 it's not so great.
> Internode uses prefix delegation to hand out a statically assigned
> /56 block to each customer, as well a link-local (i.e. fe80::)
> address for each end of the PPP link. I'm using wide-dhcp6-client to
> handle dhcpv6 for this, and it's working properly as far as I can
> tell - I get the prefix delegation, and dhcp6c sets up the correct
> addresses on the internal interfaces, which radvd then hand out
> exactly as they should. I can ping the remote end of the PPP link
> without any issues (once I figured out that ping6 requires you to
> specify the interface in this case). The problem is, I can't ping
> anything beyond the remote end of the link - everything I send
> disappears.
> Initially I had a set of firewall rules set up (after all, with v6
> my internal network is visible to the outside world - that's half
> the point of setting this up). When I realised there were problems,
> I tossed the whole thing, flushed everything and still got the same
> result. I also tried manually going in and setting up all the global
> addresses, to make sure that there wasn't something odd going on
> with the way dhcp6c was doing stuff - no change. I even tried
> setting the link MTU to something less than the 1492 that it
> defaults to, just in case there was something odd going on there -
> no change again.
> Finally, the Internode tech support line was surprisingly well
> informed about IPv6, but were a bit lost when it came to my setup -
> they couldn't suggest anything very useful, and their last
> suggestion so far was to try a different ADSL modem. I don't know
> how that will make any difference, since the modem is simply
> bridging the connection across to my server which is handling
> everything above that layer (which includes all the IPv6 stuff)
> So, to summarise: I have a notionally working IPv6 PPP link (since I
> can ping the far end), but it doesn't seem to be able to send
> anything to the outside world and the outside world doesn't seem to
> be able to send anything back. This is very secure, but I think I'd
> like a little more functionality from my network . . .
> Oh, one final note: the IPv4 side of things works perfectly in this
> setup - it's how I'm sending this email right now.
> Can anyone suggest anything that I might have missed, or that the
> Internode people might have missed? I'm totally at a loss here.
> Simon
> --
> PGP public key Id 0x96263cef
> Homepage:http://himi.org


Russell Weatherburn

mailto:russell at oxyoss.net

More information about the linux mailing list