[clug] Internet connectivity

Aeriana aeri-clug at quasarnet.org
Fri Mar 2 00:22:35 MST 2012

Unfortunately there's no TL;DR version, so here it goes... ;)

When your Internet drops out, are you losing line sync? If not, does 
your PPP session drop? Lights on your modem will tell you that.

If you do lose line sync and you use ADSL2+, try forcing the modem to 
use G.dmt aka do ADSL1, this can help with stability issues. If it fixes 
your problems, go talk to your ISP.

What does your SNR margin and line attenuation look like? With normal 
ADSL2, 6 for SNR is ideal, if it's too low or too high then talk to your 
ISP. Or if your attenuation is something like 50 or 60, then it wouldn't 
be right either.

Have you tried your modem in bridged mode?

Maybe hook up your Linux box directly and tcpdump on the PPP interface, 
watch the LCP packets - you should see LCP Echo-Request and Echo-Reply 
packets. By default the session gets dropped if no Echo-Reply is 
received after 3 or something Echo-Requests.

If you don't lose line sync and such, maybe the ISP changed something 
weird on their end...

For example, last year, one day I couldn't even load speedtest.net but 
some other sites worked fine after a few refreshes (I didn't change 
anything on my end). However I found out that I could with my ISP's web 
proxy and I even got pretty much my line speed when I did the test – 
that's when I got really confused. I eventually solved my own problem 
(after a couple of hours looking at traffic dumps) but I still wonder 
what my ISP changed on that day.

For me, traffic dump basically looked like this:

1. Me -> SYN -> remote web server
2. remote web server -> SYN/ACK -> me
3. me -> ACK -> remote web server
4. me -> GET /url -> remote web server
5. remote web server -> ACK -> me (this packet has Win=<large number> 
indicating large packet coming up next)
6. (I never saw what should be here, but stupid me for dumping traffic 
on the PPPoE interface not the ethernet interface bridged to modem so I 
didn't know who was doing the dropping)
7. (10min later) remote web server -> TCP RST -> me, web browser finally 
says timed out

All types of traffic that had large packets were affected. I spent quite 
a while thinking it was the MTU since I got bitten by that before, but 
nope, it was MSS. Got my router to do packet reassembly and peg the MSS 
value to 1452 and it was all good. Apparently I wasn't the only DSL 
customer who got bitten by it that time.

However that shouldn't be it in your case since store bought modems are 
quite good at not doing stupid things like that. That is unless the ISP 
stuffed up and pegged something lower than what it should be.

I'm still willing to loan you a Cisco 877 if nobody else is offering you 
a modem that's easier to configure.

If the connection between you and your ISP is "fine" when your Internet 
drops out, do a traceroute to Google (perhaps by its IP address) when it 
drops and see how far you get.



More information about the linux mailing list