[clug] xorg config

David Tulloh david at tulloh.id.au
Fri Aug 28 22:49:09 MDT 2009

Mike Carden wrote:
> Thanks Dave.
> I dropped a "Module" section into xorg.conf with glx and others in it.
> I also tried adding the intel driver to the "Device" section but no
> joy. Just in case I tried i810 instead of intel but still no joy. My
> xorg log file contains these clues:
> mc at alloy:~$ less /var/log/Xorg.0.log | grep -i glx
> (II) "glx" will be loaded. This was enabled by default and also
> specified in the config file.
> (II) LoadModule: "glx"
> (II) Loading /usr/lib/xorg/modules/extensions//libglx.so
> (II) Module glx: vendor="NVIDIA Corporation"
> (II) NVIDIA GLX Module  96.43.05  Tue Jan 22 20:11:30 PST 2008
> (II) Loading extension GLX
> (EE) intel(0): [dri] I830CheckDRIAvailable failed: glx not loaded
> (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
Hi Mike,

The problem is that nvidia replaces the GLX module for it's nvidia-glx 
driver.  Intel uses the standard mesa driver.

You need to install libgl1-mesa-glx and remove the nvidia glx driver, 
unfortunately there are multiple alternative nvidia glx packages, the 
main one is nvidia-glx.
Installing libgl1-mesa-glx and seeing if it conflicts would probably be 
the easiest way.

To check if it's right look at the file 
/usr/lib/xorg/modules/extensions/libglx.so with the nvidia glx it's a 
symlink to the nvidia file (at least on my nvidia box), with mesa it's a 
normal file.  Also my nvidia version is 1.2MB, my mesa is 330k.

I have no idea what happens if you want to use both an intel and nvidia 
card in the same computer using GLX, I suspect sobs of despair would 
have to feature somewhere.


More information about the linux mailing list