[clug] (MythTV) LIRC + TView99 card - IR problem

Ian Bardsley ifb777 at tpg.com.au
Fri Jul 25 06:55:28 GMT 2008

Hi Andrew

No problems.  I'm now annoyed that i threw the card away.

I well understand your tenacity.  I too hate it when things that should 
work, don't.  I shudder to think how much of my life I have spent 
chasing down solutions to problem technology.  However it does keep me 
out of the pub.

I have no experience with Mythdora but I can say that Mythbuntu is 
pretty close to being a very simple way to get Myth up and running with 
a minimum of fuss and frustration.  Of course it doesn't do the backend 
and front end config for you but it does provide a tidy environment in 
which to get a myth box working.  My last install took just 35 minutes 
wo to go with the exception of running shepherd which takes a long time. 
You might like to torrent the ISO and run it as a live CD and check it 
out. Without looking I can't be certain but I'm pretty sure that 
lirc_gpio is covered.

Hope ya get where ya want to be


Ian B

Andrew Smith wrote:
> Thanks for the feedback Ian.  Fortunately I've had no problems getting it
> working tuning TV, selecting different sources (Composite in) for viewing
> a camera with xawtv and Zoneminder.  I'm not shy of taking your advice
> though and buying a solution; it's just bugging me now and I have to win
> over it :)
> How does MythBuntu fair compared to MythDora?  I was impressed that the
> setup was all autodetected, but a little disappointed that MythDora only
> provides a limited lirc driver set (no lirc_gpio).  Then again I tried
> recompiling lirc and fell into a dependancy hell which left me spinning.
> Andrew
>> G'Day Andrew
>> I'm not the bearer of good news i'm afraid,  my first attempt with
>> Mythtv was with on of these tuner cards and I never managed to get it
>> working even as a tuner.  After many attempts, some great help from
>> various list members and a deal of frustration, I just bought a DVB
>> device.
>> For what it's worth I aquired via E-Bay some time ago a Micro$oft MCE
>> remote which has a nice feature of incorporating 2 programmable ir
>> senders as will as an ir receiver which allows control of the TV as well
>> as Myth with the one remote.  I use Mythbuntu now and this device
>> installed itself as part of the Mythbuntu installation process and apart
>> from a couple of errors in the in the LIRCD file,  worked without
>> further intervention.  Prior to that I was just using a simple serial
>> remote which also worked fine for Myth.
>> Hope you have better luck that I did but if all else fails there are
>> some fairly cheap solutions available to you as alternatives.
>> Regards
>> Ian Bardsley
>> Andrew Smith wrote:
>>> Hi List,
>>> Firstly, I have to say that Myth is a kick-arse bit of open source.
>>> All of my hats are off to those who've contributed to it.
>>> I have a TView99 Analogue tuner card from about a billion years ago
>>> that I'd like to use as my IR receiver.  My main tuner is a Twin HD
>>> card (without IR), I threw the TView card in cause I had it, would
>>> like to tune Analogue and need IR.  I'm hoping someone on the list
>>> happens to have one of these cards working, or can steer me on
>>> diagnosis of the problem.
>>> My Distro is MythDora (cause it's quick).  I have the card tuning fine
>>> - bttv auto detects the correct card type, and the IR function seems
>>> to be correctly found and provides /dev/input/event6 for me to use
>>> with irrecord (irrecord -H dev/input -d /dev/input/event6 lircd.conf)
>>> The issue is that irrecord times out after 10 seconds with:
>>> Hold down an arbitrary button.
>>> <10 secs>
>>> irrecord: gap not found, can't continue
>>> irrecord: closing '/dev/input/event6'
>>> I'm thinking it might even be a hardware problem - I'm pretty sure I'm
>>> using the correct IR lead (white stereo 3.5mm plug) - that's where I'm
>>> hoping someone has one and can confirm.  I haven't located the
>>> original remote, but have been hoping that at least one of the others
>>> I've tried (including a Hauppauge x50 remote) should've shown up
>>> something.
>>> From what I understand, irrecord is talking directly to the
>>> module/card, so lircd isn't running or configured at this point.
>>> Other output below.
>>> An help/pointers appreciated!
>>> Thanks
>>> Andrew
>>> dmesg:
>>> bttv: Bt8xx card found (0).
>>> ACPI: PCI Interrupt 0000:04:00.0[A] -> GSI 16 (level, low) -> IRQ 16
>>> bttv0: Bt878 (rev 2) at 0000:04:00.0, irq: 16, latency: 64, mmio:
>>> 0xd8001000
>>> bttv0: detected: (Askey Magic/others) TView99 CPH06x [card=38], PCI
>>> subsystem ID is 144f:3000
>>> bttv0: using: Askey CPH06X TView99 [card=38,autodetected]
>>> bttv0: gpio: en=00000000, out=00000000 in=00ffefff [init]
>>> bttv0: tuner type=1
>>> bttv0: i2c: checking for MSP34xx @ 0x80... not found
>>> bttv0: i2c: checking for TDA9875 @ 0xb0... not found
>>> bttv0: i2c: checking for TDA7432 @ 0x8a... not found
>>> All bytes are equal. It is not a TEA5767
>>> tuner 1-0060: chip found @ 0xc0 (bt878 #0 [sw])
>>> tuner-simple 1-0060: type set to 1 (Philips PAL_I (FI1246 and
>>> compatibles))
>>> tuner 1-0060: type set to Philips PAL_I (FI12
>>> tuner-simple 1-0060: type set to 1 (Philips PAL_I (FI1246 and
>>> compatibles))
>>> tuner 1-0060: type set to Philips PAL_I (FI12
>>> bttv0: registered device video0
>>> bttv0: registered device vbi0
>>> bttv0: PLL: 28636363 => 35468950 .. ok
>>> input: bttv IR (card=38) as /class/input/input6
>>> bt878: AUDIO driver version 0.0.0 loaded
>>> bt878: Bt878 AUDIO function found (0).
>>> ACPI: PCI Interrupt 0000:04:00.1[A] -> GSI 16 (level, low) -> IRQ 16
>>> bt878_probe: card id=[0x3000144f], Unknown card.
>>> cat /proc/bus/input/devices:
>>> I: Bus=0001 Vendor=144f Product=3000 Version=0001
>>> N: Name="bttv IR (card=38)"
>>> P: Phys=pci-0000:04:00.0/ir0
>>> S: Sysfs=/class/input/input6
>>> U: Uniq=
>>> H: Handlers=kbd event6
>>> B: EV=100003
>>> B: KEY=10afc336 2150a48 0 0 0 404 80010000 190 4801 1e0000 4400 100000
>>> 10000ffc

More information about the linux mailing list