[clug] xming/slackware/win xp question

David Saunders drs8h at iinet.net.au
Tue Apr 29 10:35:21 GMT 2008

  I have been trying to run X client output from my slackware 12.0 linux 
box to display on my win xp sp2 box without success.
  I have an adsl 2+ Belkin router provided by IINet and both machines 
are in my home office.
  I am using Xming + it's font package and have alternated between putty 
and secureCRT in trying to get x11-forwarding going.  The instructions 
are pretty trivial--start Xming, start an ssh -X (or -Y)  session from 
the win xp system to the linux system, set DISPLAY (although some 
instructions sometime indicate that this is unnecessary for an ssh 
tunnel), and start the x client from within the ssh session on the linux 
box (it should display back to the win xp box).
  I have turned off the win xp firewall, checked the router for any 
possible problems from it, and have tried lots of permutations, all 
without success.  I have also run Xming without the -clipboard option, 
because of comments I found on Google indicating that this causes 
problems of some sort.
  I have tried to be patient and allow the X dialog to complete 
(although the machines are not excessively old), but no reward has been 
  Finally, I sometimes observe that Xming will occasionally have 1 
client connected, but nothing displayed.

  Any ideas would be appreciated.  Thanks,
Dave Saunders

More information about the linux mailing list