[clug] Can't login at all

Darryl Luff darryl at snakegully.nu
Mon Jul 2 15:21:29 GMT 2007

Carlo Hämäläinen wrote:
>> Hi,
>> Yesterday I did this in Debian: aptitude purge `deborphan --guess-all`
>> Not a terribly smart idea. Today I can't login. I can't even enter a
>> password, it just says "Authentication failed". Same behaviour on the
>> console or on gdm.
This may be unrelated to your purge. My home machine did that the other 
day too after a normal 'aptitude upgrade'. I found that the 
/etc/pam.d/common-auth file had been renamed to '/' (a single forward 
slash). And I also found that winbind was core dumping so I couldnt 
authenticate via it. Two problems in one. Renaming '/etc/pam.d/\/' back 
to /etc/pam.d/common-auth and upgrading winbind and samba to the version 
in unstable (3.0.25b-1+b1) fixed the problem.

>> I can't find anything in /var/log/* about pam failures on login (I
>> presume this is a pam problem?). I tried reinstalling all the pam
>> modules (via a Knoppix boot and then chroot) but it still doesn't
>> work.
>> Any ideas?
>> -- Carlo

More information about the linux mailing list