[clug] i945 mobo unable to boot SATA

Darren Freeman daz111 at rsphy1.anu.edu.au
Wed Jul 12 18:02:13 GMT 2006

Hi all,

I have sunk countless hours into trying to get a pair of authentic Intel
motherboards, i945gnt, to boot from SATA drives under Linux.

I have tried:

Mandriva 2006 - installed fine, couldn't boot due to unknown lockup
during init

Fedora Core 5 - crashed on the second screen after the installer started

SUSE Linux 10.1 - installed fine, couldn't boot due to some SATA related

It's as though one of the peripherals which gets started from the
regular boot is suddenly blocking the SATA controller, as the drives are
mounted fine and then later, boom everything stops with errors.

I managed to get the SUSE system working off a PATA drive although then
when it tried to start X, it locked. I think this is a different problem
and I may have seen it under Mandriva too.

In short, nobody should ever buy a genuine Intel and try to install
Linux, no matter how many drugs they are on. I wanted an AMD but
Techwarehouse had such a limited range in the budget boards that I went
for a Celeron D. Never again!!!

But in case somebody knows what's going on, I'm begging for advice!

I can't find any reference to this problem by Googling, and whenever
I've seen this chipset mentioned nobody said anything about this

Have fun,

More information about the linux mailing list