[clug] Fedora 3 security update kills Linux install

david howe david at qednet.biz
Tue Jun 28 09:25:50 GMT 2005

Pearl Louis wrote:

>Well, just as the title says.  About 10 minutes ago I boot into Fedora
>3.  Like a good little girl I go, "Well, what about security updates?"
> I run "yum update" and see *one* security update (for
>selinux-policy-target I think).  Everything is running fine at this
>point and has been for months.  Everything was running fine minutes
>*before* I applied the security update.  No problems.  I install the
>update.  Immediately after the update, everything goes to hell, quite
>literally.  Everytime I try to run a program e.g. Matlab, Firefox I
>get an error message similar to:
>"error while loading shared libraries:/lib/tls/libc.so.6: cannot apply
>additional memory protection after relocation: Permission denied."
>OK, maybe selinux did something to my computer.  Reboot (yes, Windows
>mentality).  Reboot fails giving me the same error message as above. 
>I manually switch the machine on and off.  Go pass grub, it starts
>uncompressing the kernel, then something about an audit comes up and
>suddenly I get the error message above with the additional line,
>"Kernel panic - not syncing: Attempted to kill init."
>Wow, I never thought a simple security update can quite literally kill
>a Linux installation like this.  I've been using Linux for a couple of
>years now (mostly Mandrake) and this has never happened before. 
>Actually this has never happened with any security update I've applied
>for anything before e.g. Windows.  I expect a bit of flakiness every
>now and then or maybe some programs to stop working at worse which
>will then require a few hours of swearing and troubleshooting but
>actually *killing* the entire installation?  This has definitely put
>me off Fedora bigtime.  I can't even apply a simple security update
>without worrying about doing backups in case my entire Linux
>installation goes poof.
>Ah well, before I wipe Fedora off as a very bad experience, does
>anyone have any idea how to potentially fix this problem?  Or at least
>save my data?
Well you might be able to boot with another device (cdrom) and then 
chroot on to your old drive, maybe running fsck first....

if you then bring up a network device you can dump your data or cp it 
onto another partition (you did run multiple partitions didnt you?)

just a thought


More information about the linux mailing list