[clug] Re: Fedora 3 security update kills Linux install

Pearl Louis pearl.louis at gmail.com
Tue Jun 28 10:04:41 GMT 2005

Well, I managed to fix the problem:


leads to:


which works.  I actually couldn't find anything in Google initially
but I think that's because this only cropped up yesterday and the
search engines haven't been updated.  It seems to me that Fedora just
completely screwed up the update.  If you hadn't actually tried to
reboot a solution seems to be to simply  downgrade
selinux-policy-targeted and everything works OK.

Thanks to everyone who replied.  As to *why* I was running SELinux,
well I wasn't entirely sure what it was about but the Fedora webpage
heavily promoted it as increasing security and making your
installation safer etc. so being rather naive I bought into it, the
same way I bought into buying an anti-virus program and downloaded
anti-spyware programs for my Windows install.  Well, that and I
*think* it might have been the default choice in the installation. 
Poor reasons probably.  I have now turned it off.

Still this issue has really turned me off Fedora.  I expect that a
Linux distribution should at least be able to produce *security
updates* for a not heavily modified install (mp3 and ntfs support,
matlab, acrobat reader and intel's fortran compiler) without you know,
rendering it completely unusable and unbootable.

I guess when they say Fedora is "experimental" they really *do* mean
"experimental" as in "even applying security updates to a nearly
stock-standard install can completely bork up your system at any
moment"  :).  I'll keep that in mind when I happily delete the
installation this weekend after backing up all my data...Any
suggestions for an alternative distro that actually *tests* its
security patches but is still relatively easy to use (sorry Paul, that
rules out Debian unforunately)?


On 6/28/05, Pearl Louis <pearl.louis at gmail.com> wrote:
> Well, just as the title says.  About 10 minutes ago I boot into Fedora
> 3.  Like a good little girl I go, "Well, what about security updates?"
>  I run "yum update" and see *one* security update (for
> selinux-policy-target I think).  Everything is running fine at this
> point and has been for months.  Everything was running fine minutes
> *before* I applied the security update.  No problems.  I install the
> update.  Immediately after the update, everything goes to hell, quite
> literally.  Everytime I try to run a program e.g. Matlab, Firefox I
> get an error message similar to:

More information about the linux mailing list