[clug] Disk wont stay in RAID-5 array

Chris Henman henman at pobox.com
Sun Jul 18 04:01:26 GMT 2004

Dear All,

I have a RAID-5 array consisting of three 40GB disks (ext3) on a machine 
running Redhat 3.0ES.  Recently one of the three disks failed; hdf.  All 
continued happily on two disks.

Yeterday I bought some new disks; 3 x 80GBs.  I replaced the bad disk 
with a new one, formated and partioned the new disk and did a 
raidhotadd.  All seemed well, see copy of lsraid -A -a md0.

[root at pinatubo root]# lsraid -A -a /dev/md0
[dev   9,   0] /dev/md0         02EF0419.559F377C.34A1ABA4.2AAE1C59 online
[dev  33,   1] /dev/hde1        02EF0419.559F377C.34A1ABA4.2AAE1C59 good
[dev  33,  65] /dev/hdf1        02EF0419.559F377C.34A1ABA4.2AAE1C59 good
[dev  34,   1] /dev/hdg1        02EF0419.559F377C.34A1ABA4.2AAE1C59 good

until I rebooted.  hdf was missing.  I did another raidhot add and all 
was well again.  I waited until the disks had completely resynced and 
tried again.  Same result.

Any suggestions as to why?


     Chris Henman
     RedBox microSystems
     ABN 70 946 135 312 

     Phone:  +61 2 6161 4640
     Mobile:   0421 597 333

     Powered by Linux - Democracy in Information Technology.


More information about the linux mailing list