[clug] IDE Stalling On nForce2 Chipset?

Darren Freeman daz111 at rsphysse.anu.edu.au
Wed Aug 11 00:17:34 GMT 2004


You are experiencing the same problem I had before getting rid of that
motherboard. I swear never to buy another nVidia chipset and run Linux
on it.

The solution is to put the following into your boot config:

"noapic nolapic acpi=off"

Note that your IDE will now run like shit but rock solid. Try passing
that in a hurry! (ouch! I take it back..)

This was originally suggested to me by David Tulloh on this list.
Message pasted below.

Have fun,


The problem is with the IO with linux, it was introduced in 2.5 and I
believe 2.4.22.  I had it for a while, I was hoping that they would fix
in 2.6.  LKML was aware of the problem, I'm not sure if they have fixed

To stop the problem you need to disable local APIC.  This needs to be
in the boot kernel options.
for asus, people reported that: "noapic nolapic acpi=off" was required
personally I found just nolapic did the trick, but I don't have an asus

There was also dicussions on the greater internet about a patch that
it for 2.4.22, and people reporting that bios updates fixed it.  I
tried either so don't know if it does/doesn't work.

More information about the linux mailing list