[clug] IDE Stalling On nForce2 Chipset?

Cody Miller kizmet at gmail.com
Wed Aug 11 09:49:09 GMT 2004

Maybe you should try 2.6.7 it works nativly with my Gigabyte 7N400
Pro2 and my Gigabyte 7N400-L1  it runs really good too :D

just a lil advice ;)

On Wed, 11 Aug 2004 10:17:34 +1000, Darren Freeman
<daz111 at rsphysse.anu.edu.au> wrote:
> Alex,
> You are experiencing the same problem I had before getting rid of that
> motherboard. I swear never to buy another nVidia chipset and run Linux
> on it.
> The solution is to put the following into your boot config:
> "noapic nolapic acpi=off"
> Note that your IDE will now run like shit but rock solid. Try passing
> that in a hurry! (ouch! I take it back..)
> This was originally suggested to me by David Tulloh on this list.
> Message pasted below.
> Have fun,
> Darren
> --------8<--------8<--------8<--------
> The problem is with the IO with linux, it was introduced in 2.5 and I
> believe 2.4.22.  I had it for a while, I was hoping that they would fix
> it
> in 2.6.  LKML was aware of the problem, I'm not sure if they have fixed
> it
> though.
> To stop the problem you need to disable local APIC.  This needs to be
> done
> in the boot kernel options.
> for asus, people reported that: "noapic nolapic acpi=off" was required
> personally I found just nolapic did the trick, but I don't have an asus
> There was also dicussions on the greater internet about a patch that
> fixed
> it for 2.4.22, and people reporting that bios updates fixed it.  I
> haven't
> tried either so don't know if it does/doesn't work.
> --
> linux mailing list
> linux at lists.samba.org
> http://lists.samba.org/mailman/listinfo/linux

Cody Miller
Alias: Kizmet

More information about the linux mailing list