Modules question

Michael Still mikal at
Tue Apr 2 06:17:27 EST 2002

On Mon, 1 Apr 2002, Simon Fowler wrote:

> On Mon, Apr 01, 2002 at 09:03:12PM +1000, Michael Still wrote:
> >
> > This is probably a silly question, but I have never really played with
> > modules before...
> >
> > I want minix on my uml debian machine. I have compiled the minix.o and
> > arranged for it to be in /lib/modules/2.4.18/fs/minix/minix.o. An insmod
> > doesn't find it. Is there special magic to make this work? Is this even
> > the right location for a 2.4.18 kernel?
> >
> I assume this is /lib/modules/2.4.18/fs/minix/minix.o on your UML
> root_fs?

It turns out the magic path is /lib/modules/2.4.18-2um/fs/minix/minix.o...

> If it is, then try booting the image and running depmod -a, then try
> modprobe minix. If you still get an error, try running insmod with
> the full path to the module - I /know/ that works with my UML setup,
> because it loads /my/ modules.

It now gives me the same error message in insmod and depmod -- "couldn't
find the kernel version the module was compiled for".

Any hints?



Michael Still (mikal at     UMT+11hrs

More information about the linux mailing list