Login problems for some users

JIMMY BEASLEY jjbeasley at fedex.com
Thu Sep 26 09:58:07 EST 2002

ntpdate  "time.server"
    on all systems having problems
stop your nisplus client service and remove /var/nis/NIS_COLD_START
nisinit -c -H "master.domainame."
    see if you can get a new /var/nis/NIS_COLD_START from your master nisplus
restart keyserv ,  automount , nscd ,
    if the nisls command returns correctly users should be able to login

Bob Edwards wrote:

> John Aasen wrote:
> >
> > Hi,
> >
> > We have a mixed Solaris/linux environment which basically has run fine for
> > over a year. But we have now got a problem with some new users. They are
> > added to the nis+ tables with nisaddcred the same way as before, but they are
> > unable to login on a Linux machine (RedHat 7.3 nisplus client). They login
> > fine on Solaris machines.
> >
> > /var/log/secure says authentication failure.
> > I've tried nisping -f on the Linux machines without any help.
> > I've tried keylogout / keylogin on a Linux machine, but keylogin fails with
> > the message:
> > Can't find unix.<pid>@<domainnames>'s secret key.
> >
> > Anyone got an idea on how to solve this problem?
> >
> > John
> I don't think that I have seen a response to this one yet.
> So, just to confirm, these users can log onto Solaris NIS+ clients but not
> onto _any_ Linux NIS+, or only a few? Can anyone else log onto the suspect
> Linux NIS+ clients? What happens if you run "nisdefaults" on these clients?
> Where you say "Can't find unix.<pid>@<domainnames>'s secret key", should that
> pid really be the users uid? Is it correct?
> Cheers,
> Bob Edwards.

More information about the linux-nisplus mailing list