Almost there, but a few problems

Bruce Baumgart baumgaba at
Thu Oct 24 02:53:44 EST 2002

Standard boiler plate:  Help!!!

Trying to add Redhat 7.3 client to an existing Solaris 8 NIS+ domain.  I am 
so close that I can see it, but a couple of problems that may even be related.

Existing setup, names munged to keep security happy.

Domain -
Sub-domain -
Server - Solaris 8
Client - Redhat 7.3 workstation install, gnome brought up at connect.
Trying to add machine to sub-domain.
Sub-domain server is my ntpd server.

I am following Marc Wrubleski's cookbook, with the following exceptions:

When I tried doing the nisinit -c -H <host>, got the infamous not served by this server

message.  So I copied a cold start file from a working Solaris box and did 
a nisinit -c -C <filename>.  That worked, as did the keylogin.  Left all of 
the PAM stuff alone, figuring that if it was OK in Redhat 7.2, it should be 
OK in 7.3.  After a reboot; domainname and nisdomainname are right; keyserv 
and autofs are running.  I am logged on as root, so nisdefaults shows the 
client box as the principal, and it is authenticated.  A niscat works.

Now the problems.

A "nisls" works.  No other nisls command does.  They all fail with not served......

I try to log on with my working-on-Solaris-machines userid.  I get logged 
on and my home directory mounted.  Because it is a very Solaris-specific 
logon profile, a bunch of mounts don't work, and the PATH is really really 
broken.  I built a .bashrc that corrects the path, and everything dealing 
with the client box seems to work.  However, a nisdefaults shows my id as 
the principle, and not authenticated.  niscat works, nisls doesn't.

I have scoured the archive file.  Not much there.  Next question - Is there 
a searchable archive online somewhere?

TIA, especially if you made it this far.......

Bruce Baumgart                  This space intentionally left blank.
Bechtel BWXT Idaho, LLC

More information about the linux-nisplus mailing list