[jcifs] Davenport - cannot mount from windows 7

Vladislav Kurz vladislav.kurz at webstep.net
Sun Apr 13 10:25:55 MDT 2014

Dear developers,

I'm not sure if I'm asking on the right place, so pleas forgive and 
redirect me if so.

I wanted to offer (seamless) webdav acces to windows clients, and found 
the davenport project. At first glance I have jumped with joy - it was 
exactly what I wanted. But after installing end testing my joy has 

Browser access works perfectly without even touching any configuration. 
But I was not able to "map drive" from windows. Neither win 7, nor server 
2003 or 2012. I have tried lots of stuff - disabling NTLM auth, allowing 
plaintext basic auth (both in windows registry and davenport), enabling 
SSL, moving jetty to default ports (80, 443). Sometimes windows did not 
even ask for password, and apparently (tcpdump) even did not connect at 
all. Perhaps some caching of failures is at work, or what. Finally I 
focused on getting windows 7 to work. (It seems that server 2012) does not 
even have a webdav client installed by default.).

I have tried other WebDAV clients (cadaver for Linux and BitKinex for 
windos - both work just fine) Finally I got to a point where I could 
capture some commutication between windows and davenport. Plaintext basic 
auth seems to work, and this is the last request and response (formatted 
to fit on line):

PROPFIND /esix-file HTTP/1.1
Connection: Keep-Alive
User-Agent: Microsoft-WebDAV-MiniRedir/6.1.7601
Depth: 0
translate: f
Content-Length: 0
Authorization: Basic *******SECRET*******==
Cookie: JSESSIONID=59hr3uicxp4f

HTTP/1.1 207 Multi Status
Transfer-Encoding: chunked
Date: Sun, 13 Apr 2014 15:50:47 GMT
Server: Jetty/4.2.27 (Linux/3.2.0-4-amd64 amd64 java/1.6.0_27)
Content-Type: text/xml; charset="utf-8"

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<multistatus xmlns="DAV:" xmlns:w="urn:uuid:c2f41010-65b3-11d1-a29f-00aa00c14882/">
    <status>HTTP/1.1 200 MultiStatus</status>
     <ishidden w:dt="boolean">0</ishidden>
     <iscollection w:dt="boolean">1</iscollection>
     <isreadonly w:dt="boolean">1</isreadonly>
    <status>HTTP/1.1 404 MultiStatus</status>

Do you have any idea what might confuse the windows web client? Why is 
there that last part with 404 status? Is there any way how to get it 

Thanks in advance

Vladislav Kurz

Smash forehead on keyboard to continue...

More information about the jCIFS mailing list