[jcifs] Accessing shares on HP X9000 using jCIFS - SOLVED

Pontus Ullgren ullgren at gmail.com
Wed Feb 15 08:28:48 MST 2012

Hello list,

This email started out as a plea for help but as I was investigating
the issue, to compose a good question, I found the solution.
Since I could not find any solution via google and since I already
started the email I thought I post it anyway.

Anyway it started when I found my self trying to use jCIFS (v1.3.17)
to access shares on a HP X9000.
This network storage system seems to be running a somewhat dated
version of Samba, however I've not been able to determine the exact

First I had problems getting it to accept the credentials disabling
extended security and forcing lmCompability = 0 solved that.

However after that I got the strangest errors.
After I connected I could not list the initial directory.
However if I started with a file listing in the initial directory and
then change directory all subsequent listings work but never in the
directory I initially connected to.

When I ran the command with higher log level and saw a behaviour which
I, in my ignorance, would describe as a race condition of sort.
Disabling command batching solved the problem.

So the configuration that made it work was
-Djcifs.smb.lmCompatibility=0  -Djcifs.smb.client.useBatching=false"

Hope this helps someone else and thanks for a great library.
// Pontus Ullgren

More information about the jCIFS mailing list