[jcifs] Connection in error

Michael B Allen mba2000 at ioplex.com
Fri Oct 6 16:16:40 GMT 2006

This just means pretty much what it looks like. The client tried to open
a socket and it never got a response. Older clients did have strange
behavior when this happend where the transport would get in a bad state. I
believe the behavior now is if multiple threads are trying to connect on
the same transport and the current one chokes (e.g. Connection timeout)
the next thread gets a "Connection in error" and resets the state to
0. The next thread should be able to succeed (unless the server still
isn't responding in which case you'll get the same error and the cycle
will continue). So when the server becomes available again the client
should recover depending on how dillegent your retry code is.

Also, the difference between 1.2.6 and 1.2.9 is only good. There were no
radical changes that should affect the behavior of your application. It
would be pretty safe to upgrade.

But check the REAMDE.txt to see what those changes were.


On Fri, 6 Oct 2006 09:53:46 -0400
"Andrew Miller" <pulazzo at gmail.com> wrote:

> I'm seeing this error in one of my deployments. I have others that
> work perfectly fine and this never occurs (this one is on a different
> domain).  After I see this once, it happens over and over.
> jcifs.smb.SmbException:
> jcifs.util.transport.TransportException: Connection in error
> jcifs.util.transport.TransportException: Connection timeout
> 	at jcifs.util.transport.Transport.connect(Transport.java:349)
> 	at jcifs.smb.SmbTransport.connect(SmbTransport.java:271)
> 	at jcifs.smb.SmbTree.treeConnect(SmbTree.java:129)
> 	at jcifs.smb.SmbSession.logon(SmbSession.java:322)
> 	at jcifs.smb.SmbSession.logon(SmbSession.java:308)
> I'm using jcifs 1.2.6 for NTLM in a custom application that looks
> mostly like an http servlet engine.
> I saw a reference in a thread from last year that suggested a
> disconnect needed to be called and am looking into patching the
> source.
> I was wondering, is this the same issue?
> Any idea what would cause this?
> I'm considering updating to 1.2.9, but am hesitant to do so with out a
> lot of testing.  Are there any changes in those updates that might
> affect this?
> Thank you,
> Andy

Michael B Allen
PHP Active Directory SSO

More information about the jcifs mailing list