[jcifs] Shared Folder

izlem Gozukeles izlem.gozukeles at emo.org.tr
Mon Apr 10 20:19:41 GMT 2006

I solved the problem one day after I posted this message.
I do not know if it is a bug or not. But I thought that I should inform
the list about the solution.

As it is seen I used the name resiYayin for the shared folder. The
problem is interesting, the i letter :)
When I used a folder name without i letter, everthing worked well.

I think the problem is the character set, ISO-8859-9,  that I am using.
This is a character set for Turkish.
In Turkish capital letter for i is not I, but it is İ.

best regards,

izlem Gozukeles yazmış:

>I am newbie to jcifs.
>I have a Debian Samba Server. its configuration is very simple:
>        workgroup = DEBIAN-MUSIC
>        security = user
>        netbios name = DEBIAN-RADIO
>        comment = For testing only, please
>        path = /home/resi/Yayin
>        read only = yes
>        guest ok = yes
>I want to reach the files at resiYayin directory.
>Everyhing is ok, from Linux konsole...
>My problem is I can not reach the content of this directory by jcifs.
>For example the below code is ok, work properly and shows the shared
>folder, IPC$ and admin$:
>        Config.setProperty("jcifs.smb.client.username", "user");
>        Config.setProperty("jcifs.smb.client.password", "password");
>        SmbFile file = new SmbFile("smb://");
>        String[] files = file.list();
>        for( int i = 0; i < files.length; i++ ) {
>            System.out.print( " " + files[i] );
>        }
>However, when I want to reach resiYayin directory, as
>        SmbFile file = new SmbFile("smb://");
>I had an exception error saying that
>jcifs.smb.SmbException: The network name cannot be found.
>What is the problem?
>I have not any problem while reaching Windows Servers. The problem is only
>for Debian.

More information about the jcifs mailing list