AW: [jcifs] DFS-Links and jcifs.smb.client.soTimeout

Michael B Allen mba2000 at
Fri May 20 20:20:04 GMT 2005

CC-ing jcifs mailing list again.

I don't understand this log. What am I looking for? Can you get a packet
catpure (

With NetworkExplorer exactly what happends? You click on a non DFS link
it's fine, but when you hit a DFS path it gives you the "Invalid access
to memory location" error?

Last I checked NetworkExplorer worked with DFS fine. I don't think I
have a DFS share on which to test it anymore though. I'll check.

There have been reports that jCIFS will not work with some DFS setups. It
has something to do with active directory. Clients somehow know in advance
what shares are DFS and do not attempt a referral. This is protocol that
I do not understand and is therefore not supported. If this turns out
to be the scenario there's not much I can do.


On Fri, 20 May 2005 11:53:22 +0200
"Marro, Donato" <marro at> wrote:

> Hi Michael,
> > > Hi,
> > > 
> > > while testing some DFS-stuff with jCIFS 1.1.10 I noticed the following
> behavior:
> > > 
> > > When I'm trying to access a DFS-Link with a newly generated NPA-Object,
> I get 
> > > the expected DfsReferral-Excpetion. Now, when I'm trying to access the
> same DFS-
> > > Link a second time (with the old NPA-Object as well as with a new one) I
> get an 
> > > "Invalid access to memory location"-Exception. This behavior only occurs
> when 
> > > there are less than <jcifs.smb.client.soTimeout> milliseconds between
> the two 
> > > trys. After waiting <jcifs.smb.client.soTimeout> milliseconds I get the 
> > > DfsReferral-Exception again.
> > > 
> > > Is this behavior the expected one?
> >
> > First, the invalid memory exception is described here:
> >
> >
> >
> > Because we have spoken before I have an inkling of what your up to so
> > I would require that you first check the NetworkExplorer servlet to see
> > how it behaves.
> I tried the NetworkExplorer and it behaves similiar to my app.
> Find some logs of this test attached to this mail.
> > If it is ok, I suspect you are not saving the NPA on a
> > server specific basis or performing the HTTP redirect properly.
> I'm saving the NPA on a server specific basis exactly like in the
> NetworkExplorer.
> Greetings,
> Donato

More information about the jcifs mailing list