[jcifs] HELP: Question about accessing Named Pipes

Michael B Allen mba2000 at ioplex.com
Mon May 16 23:19:49 GMT 2005

Please send all messages to the jCIFS mailing list (provided they don't
have questionable attachments).

Amlan Chatterjee said:
>> smb://WORKGROUP\\;user:pass@mypc/IPC$/PIPE/fooit
>> > still gives the same
>> > exact error.
>> Well this is definately going to give you an error because the '\\' in
>> there is invalid. See the Overview page of the API documentation for
>> proper SMB URL usage.
> Take a look at your example properties file torture.prp or torture2.prp
> torture.src.url = smb://dom\;miallen:pass@server/pub/
> This wont compile since \; is an illegal escape chartacter. Thats why
> I made that '\\;'.

That's a properties file escape character to suppress the interpretation
of the ';'. You will also see this in shell scripts.

> Anyway, I tried the same URL without setting the domain or
> username+password
> (i.e. putting them in a properties file and loading them using
> Config.load()). Doesnt
> make any difference whatsoever in the exception and output.
> I tried with each of the following urls
> smb://user:pass@mypc/IPC$/PIPE/foo
> smb://user:pass@mypc/IPC$/foo
> smb://mypc/IPC$/PIPE/foo
> smb://mypc/IPC$/foo

I think you want:


>> Any ideas about what am I missing ?
>> Reading the documentation?
> Actually I did read the documentation.
> Its insufficient and at places possibly erroneous.

Funny. You're the first person to complain about this.

> b) Some parts of the doc. are possibly incorrect. For ex. the page states,
> "if
> the property "jcifs.properties" defines the location of a
> java.util.Properties file, all properties will be loaded from it." Thats
> not
> the case at all. Defining this as a System Property has no effect. I had
> to
> load them manually using Config.load()

What the heck are you doing? I've never heard anyone having a problem with

> Thanks. FYI, I tried the CallNamedPipe and WaitNamedPipe examples. Neither
> of them seems to work.

Yes, again I think there is a bug. I'll look at it (eventually).

>> PS: Note the Jarapac examples *do* work. I guess I broke regular pipes
>> making the DCE pipes work.
> Mike, this is not Jarapac. I can connect to a remote DCE Pipe using
> Jarapac
> just fine. Have no problem there. Here however, I am using JCIFS. All I am
> trying to do is to access a named pipe on a remote linux box, exposed
> using
> Samba IPC and ofcourse from from Java using the JCIFS SmbNamedPipe API.
> IMHO, what will really help is a complete example of creating, exposing
> and
> accessing a named pipe for Win32 as well as Unix. That way there is less
> chance of confusion and error.

Amlan, I think you're frustrated and as a result you're exacerbating the
problem a little with dumb mistakes. That doesn't help. And I do not
always feel like I have the constitution to go back and fourth with you.


More information about the jcifs mailing list