[jcifs] Can't authenticate with newer samba

Need Coffee need.coffee at gmail.com
Thu Jun 2 03:43:14 GMT 2005

I am using Davenport 0.9.10 with its bundled jcifs-0.9.7 just fine
with samba 2.2.x.
Unfortunately, upgrading samba to 3.0.14a causes authentication to fail from
Davenport, even though PCs can still authenticate fine.
In looking at what's on the wire, it looks like a problem with the
NTLM auth level.
Downgrading samba back to 2.2.x allows logins to work just fine again.
 I ran both
versions off the same smb.conf.

I've tried updating jcifs to several recent versions, and tried a few
older releases
of samba (3.0.11 leaps to mind) all without success.  I also tried
tweaking various
things in smb.conf as well as Davenport's web.xml (one at a time, of
course ;) without
any success.

I assume some default has changed in samba, which then requires either a config
or code change in Davenport or jcifs, but I'm having a bit of trouble
what is at work.

Any help is appreciated, thanks in advance.

More information about the jcifs mailing list