[jcifs] jcifs connection problem from unix box

Michael B Allen mba2000 at ioplex.com
Mon Jul 18 19:58:50 GMT 2005

On Mon, 18 Jul 2005 15:30:25 -0400
"Sherman, Jeffrey - eSpeed" <JSherman at espeed.com> wrote:

> I had tried jcifs.smb.client, just ran through it again with no luck
> (there's 2 nics, I thought it may have been using the wrong one)

Did you restart the container?

If that fails try changing jcifs/smb/SmbTransport.java:228 to the

  if (localAddr == InetAddress.getLocalHost()) {
      socket = new Socket( address.getHostAddress(), 139 );
  } else {
      socket = new Socket( address.getHostAddress(), 139, localAddr, localPort );

Now, recompile with 'ant jar', reinstall the jar, UNSET
jcifs.smb.client.laddr, restart the container and try again.

I'm 99% sure this is the problem.

If you run the following program does it choke with the same error?

public class SocketTest {
    public static void main( String[] args ) throw Exception {
        Socket s = new Socket( "", 139, InetAddress.getLocalHost(), 0 );


More information about the jcifs mailing list