[jcifs] Remote command Execution?

michaelm michaelm at managesoft.com
Tue Sep 7 14:51:38 GMT 2004

Hi Mike,

Im Having a little trouble connecting to the windows machine using the
example you sent me.

In ethereal I get the following from the windows machine:
ATSVC NetJobAdd response, Unknown error 0x00000005

Im invoking the test app like this:
java -classpath
../jarapac.jar:../ncacn_np.jar:../ntlm-security.jar:../lib/jcifs-0.9.7.jar:.  -Djcifs.properties=example.properties  TestAtsvc mmehlem-pc.win.mgsft.com

(if i specify the wrong netBIOS name for the machine, then i get a
connection failed Exception on the console as expected. So it seems to
be able to find the machine)

I have changed the credentials and the domain in example.properties file
to be correct. I dont see where you specify the NT Domain credentials

Although, I seem to get the same error if i specify the properties file
or not.

Do you any idea what I might doing wrong?

Did this example work for you  (besides the scheduling issue with

Any help would be much appreciated.

Many Thanks,

On Fri, 2004-09-03 at 04:48, Michael B Allen wrote:
> Michael B Allen said:
> > Then run your TestAtsvc program. It probably won't work the first time
> > around but
> This was very easy. The attached works with idlc + Jarapac. But I don't
> know how to interpret the job_time value. It's not seconds from 1970. It's
> relative to 12am or something like that. I tried 0xFFFFFFFF thinking that
> might be interpreted as "now" but it didn't work. I think you might have
> to somehow get the server time and then compute the job_time + 5 seconds
> or something like that. If you figure it out pls let us know.
> Mike

More information about the jcifs mailing list