[jcifs] Intermittent Broken Pipes

todd todd_run at yahoo.com
Thu Jul 24 10:12:16 EST 2003

I'm get intermittent errors trying to create directories on a Linux/Smb 
machine using mkdirs.  I've tried using 0.7.9 and 0.7.11.  This tends to 
work fairly reliably if I run the code on a Linux machine with a Linux 
target machine or if I run it on either platform to a Windows target. 
Running the code on Windows to a Linux target yeilds anywhere from 0% 
success (yesterday afternoon) to 50% success (today).

The error code from the SmbException is 5000 with a message of "Timeout 
waiting for response from server".  Here is a sample of the error from 
the samba log on the target machine:

[2003/07/23 14:57:13, 0] lib/util_sock.c:write_socket_data(499)
   write_socket_data: write failure. Error = Broken pipe
[2003/07/23 14:57:13, 0] lib/util_sock.c:write_socket(524)
   write_socket: Error writing 43 bytes to socket 12: ERRNO = Broken pipe
[2003/07/23 14:57:13, 0] lib/util_sock.c:send_smb(704)
   Error writing 43 bytes to client. -1. (Broken pipe)

Any ideas why this is occuring or what steps I can take to troubleshoot 
it and make it more reliable?

Thanks in advance


More information about the jcifs mailing list