[jcifs] Timeout connecting to AS400 using jcifs.

Allen, Michael B (RSCH) Michael_B_Allen at ml.com
Sat Apr 5 09:42:29 EST 2003

> -----Original Message-----
> From:	DTooke at interproconsulting.com [SMTP:DTooke at interproconsulting.com]
> Sent:	Friday, April 04, 2003 2:42 PM
> To:	Allen, Michael B (RSCH)
> Cc:	'DTooke at interproconsulting.com'; jcifs at lists.samba.org
> Subject:	RE: [jcifs] Timeout connecting to AS400 using jcifs.
> Mike,
> I think I found the problem.  At least, I found the solution...I'm still not sure what the problem was.
> On the NETSERVER configuration, the domain name was set to an old domain.  All our PC's were set to another domain.   When I changed the NETSERVER configuration to the new domain.  I was able to run
> ListFiles on both my pc and the AS400.
> I don't quite understand why it didn't work when I ran ListFiles directly on the AS400 previously, but it does work now.   I would have thought the domain would have, in effect been irrelevant when
> you are on a machine and talking to that same machine.
> But, anyway, what do I know? it works now.
	It shouldn't make any difference. From the -Dlog=ALL trace you sent me it looks like the server
	is responding to the SMB_COM_NEGOTIATE reqest but jCIFS didn't read the complete
	response. It's expecting something more. We would need a packet capture to see what this
	server is really doing. Someone has a bug I think.

	Also is OS400 EBCDIC encoding? I don't think we fully abstracted the host encoding until 0.7. I
	see you're using IBM's 1.2 and jcifs-0.6.8.


More information about the jcifs mailing list