[distcc] "failed to exec: No such file or directory" error

Fergus Henderson fergus at google.com
Wed Sep 5 03:20:43 MDT 2012

You're right that setting DISTCCD_PATH will overwrite PATH as far as
distccd is concerned.
But are you setting DISTCCD_PATH before starting distccd?
How are you starting distccd -- manually, or via a system service?

The error message from dcc_execvp comes after executing execvp() failed.
execvp() is a system call which just executes the named executable,
in this case "i686-pc-linux-gnu-gcc", from the PATH.
So at the point where the error occurs, the PATH definitely does not
contain an "i686-pc-linux-gnu-gcc" program that can be executed.
And distccd will indeed set PATH from DISTCCD_PATH.

Is this perhaps a permissions error? If the distccd program is running as
user "distcc", and i686-pc-linux-gnu-gcc is a symbolic link to a file in a
directory that the "distcc" user doesn't have permission to access, that
might explain it.

On Tue, Sep 4, 2012 at 8:10 AM, Dainius (GreatEmerald) <pastas4 at gmail.com>wrote:

> Now I tested by copying the i586-pc-linux-gnu-gcc to /usr/local/bin as
> i686-pc-linux-gnu-gcc to make absolutely certain (as /usr/local/bin is
> in the PATH by default), but I still get the same error... I also set
> DISTCCD_PATH to /usr/local/bin, and still the exact same error.

Fergus Henderson <fergus at google.com>

"Defend the user, exclude no one, and create magic." -- Eric Schmidt.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.samba.org/pipermail/distcc/attachments/20120905/6670b455/attachment.html>

More information about the distcc mailing list