[distcc] make deb error

Tomas Norman tomas at redgoblin.net
Tue Feb 10 14:35:09 GMT 2009


I'm running Ubuntu 8.10 64-bit, gcc 4.3.2, python 2.5.2 (don't know if 
you need to know more..)

First I run "./configure --disable-Werror", seems OK, (but if I just use 
"./configure" I get an error on emaillog.o ... or something... when I 
try to use "make")

But when I try to use "make deb" I get an error.
rm -f "distcc-3.1.tar"
rm -r "distcc-3.1"
cp "./NEWS" "distcc-3.1.NEWS"
cd packaging && ./rpm.sh distcc 3.1
trap: 62: SIGHUP: bad trap
cd packaging && ./deb.sh distcc 3.1 *.rpm
File "*.rpm" not found.
make: *** [deb] Error 2

What am I doing wrong?? Is something missing?
I have tried both as user and sudo.

I also have tried it on two different machines, both running Ubuntu 8.10 
x64, gcc 4.3.2, python 2.5.2.

If I use "--disable-Werror" then make, make install it seems to work. 
Haven't tried using it to compile anything yet though.

It really looked easy, just run ./configure && make && sudo make install :)

Thanks in advance

More information about the distcc mailing list