[distcc] distcc and -finput-charset option

Martin Pool mbp at sourcefrog.net
Tue Mar 21 11:30:50 GMT 2006

On 17 Mar 2006, Ilja Golshtein <ilejn at yandex.ru> wrote:
> Hello!
> I've tried distcc 2.18.3 to
> build by own project on
> two i386 boxes with Fedora Core 4.
> Command line looks like this
> ==
> distcc -fPIC -fshort-wchar -g -D_DEBUG -O0 -Wno-deprecated -Wno-pointer-arith -finput-charset=WINDOWS-1251 -Wno-invalid-offsetof -USE_COMPILER_EXCEPTIONS -D__MY_STL_IMPL -I./src -I.
> ....
> ==
> Diagnosis is
> cc1plus: error: failure to convert WINDOWS-1251 to UTF-8
> Of course it is compilable without gcc on both boxes.
> I tried to invoke distccd with LANG utf8 or something
> but no luck.

distcc is not adding this option; it must be coming from your makefile.
The likely cause is that this option is not supported by the version of
distcc on the server.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: Digital signature
Url : http://lists.samba.org/archive/distcc/attachments/20060321/0ede686c/attachment.bin

More information about the distcc mailing list