[distcc] mkdir /root/.distcc failed: Permission denied

Niki Kovacs contact at kikinovak.net
Sat Mar 18 08:26:54 GMT 2006


I'm an Austrian writer living in Montpezat (South France), and an enthusiastic 
100% GNU/Linux user since 2001. I use Slackware Linux exclusively, and I'm 
very happy with it. 

I'm currently busy building KDE 3.5.1 from source, to integrate 
dbus/hal/pmount support, and also to tweak it a little bit, leave redundant 
apps out, modify compile options here and there. Unfortunately, KDE is a bear 
to build. One of the guys on alt.os.linux.slackware pointed out distcc, which 
I hadn't heard of, and I have a sixth sense that this will change my life. I 
have four Pentium IV PCs here at home, so the idea to combine processor power 
sounds very appealing.

A first manual try-run (Mplayer, Qt) was *very* conclusive. Installed distcc 
on three machines, started the daemon manually, and yessssssss: compile time 
for Qt went down from 73 to 26 minutes! 

Since programs like Qt can only be built as root, I run make as root... there, 
I get the following error message: 

ERROR: mkdir /root/.distcc failed: Permission denied

I figure this is because distccd runs as user nobody (I explicitly told it to 
do so). 

Q1: what user should distccd be run as ideally? I tried --user root, but he 
didn't like it and exited.

Q2: to have a readable log file, I told distccd to output to /var/log/distccd, 
and then chown nobody.nobody /var/log/distccd. What's the orthodox way to 
solve my permission problem above? Manually create /root/.distcc, and then 
chown -R nobody.nobody for that directory? And if so, do I have to do this on 
all the server machines, or only on the client? 

Go easy in your explanations. I'm a writer, not a developer.


Niki Kovacs 

More information about the distcc mailing list