[distcc] write .o files on Tru64 4.0

Gregoire Banderet gregoire.banderet at nagra.com
Thu Apr 1 15:01:59 GMT 2004


I've compiled the latest version of distcc on Tru64.
When I use it, all distccd compile my cpp files (I see that they spend time) , but they fail to send the result to my localhost.
Note that I tried to compile distcc with/wo SENDFILE and with/wo HAVE_MMAP. I also tried to compile with cxx and gcc.
And I tried to be on a local filesystem (not NFS) too...

On my localhost, I have empty .o files (those compiled on remote hosts).

Log from distccd:

> distccd --daemon --no-detach --log-stderr --verbose
distccd[15351] daemon's PATH is /soft/sep/SEPv1.8.0_UNIX4.0g/libraries/PDS3/PDM/genPO:/users/banderet:/soft/insure/bin.alpha4:/soft/ccase/bin:/users/banderet/bin:/soft/nagra/bin:/soft/utils/bin:/usr/local/bin:/usr/bin:/usr/bin/X11:/soft/gnu/bin:.:/soft/totalview/current/bin:/usr/sbin:/soft/local/oracle/product/
distccd[15351] listening on
distccd[15351] 1 CPU online on this server
distccd[15351] allowing up to 3 active jobs
distccd[15351] not detaching
distccd[15351] already a process group leader
distccd[15351] preforking daemon started (2.13 alphaev67-dec-osf4.0g, built Apr  1 2004 16:39:57)
distccd[15351] up to 1 children
distccd[15351] up to 2 children
distccd[15351] up to 3 children
distccd[15531] connection from
distccd[15531] got DIST00000001
distccd[15531] got ARGC00000008
distccd[15531] reading 8 arguments from job submission
distccd[15531] got ARGV00000003
distccd[15531] argv[0] = "cxx"
distccd[15531] got ARGV00000003
distccd[15531] argv[1] = "-O4"
distccd[15531] got ARGV00000004
distccd[15531] argv[2] = "-ptr"
distccd[15531] got ARGV0000002c
distccd[15531] argv[3] = "./RELEASE-ORA8-SEP1.8.0-D4.0G/cxx_repository"
distccd[15531] got ARGV00000002
distccd[15531] argv[4] = "-c"
distccd[15531] got ARGV00000002
distccd[15531] argv[5] = "-o"
distccd[15531] got ARGV00000028
distccd[15531] argv[6] = "RELEASE-ORA8-SEP1.8.0-D4.0G/EcsHandler.o"
distccd[15531] got ARGV0000000e
distccd[15531] argv[7] = "EcsHandler.cxx"
distccd[15531] got arguments: cxx -O4 -ptr ./RELEASE-ORA8-SEP1.8.0-D4.0G/cxx_repository -c -o RELEASE-ORA8-SEP1.8.0-D4.0G/EcsHandler.o EcsHandler.cxx
distccd[15531] scanning arguments: cxx -O4 -ptr ./RELEASE-ORA8-SEP1.8.0-D4.0G/cxx_repository -c -o RELEASE-ORA8-SEP1.8.0-D4.0G/EcsHandler.o EcsHandler.cxx
distccd[15531] found object/output file "RELEASE-ORA8-SEP1.8.0-D4.0G/EcsHandler.o"
distccd[15531] found input file "EcsHandler.cxx"
distccd[15531] compile from EcsHandler.cxx to EcsHandler.o
distccd[15531] output file RELEASE-ORA8-SEP1.8.0-D4.0G/EcsHandler.o
distccd[15531] input file EcsHandler.cxx
distccd[15531] got DOTI000abdb2
distccd[15531] received 703922 bytes to file /tmp/distccd_54ea29dd.ii
distccd[15531] 703922 bytes received in 0.106384s, rate 6462kB/s
distccd[15531] changed input from "EcsHandler.cxx" to "/tmp/distccd_54ea29dd.ii"
distccd[15531] command after: cxx -O4 -ptr ./RELEASE-ORA8-SEP1.8.0-D4.0G/cxx_repository -c -o RELEASE-ORA8-SEP1.8.0-D4.0G/EcsHandler.o /tmp/distccd_54ea29dd.ii
distccd[15531] changed output from "RELEASE-ORA8-SEP1.8.0-D4.0G/EcsHandler.o" to "/tmp/distccd_573929dd.o"
distccd[15531] command after: cxx -O4 -ptr ./RELEASE-ORA8-SEP1.8.0-D4.0G/cxx_repository -c -o /tmp/distccd_573929dd.o /tmp/distccd_54ea29dd.ii
distccd[15531] /usr/bin/cxx is a safe symlink to ../lib/cmplrs/cxx/deccxx_driver
distccd[15531] forking to execute: cxx -O4 -ptr ./RELEASE-ORA8-SEP1.8.0-D4.0G/cxx_repository -c -o /tmp/distccd_573929dd.o /tmp/distccd_54ea29dd.ii
distccd[15531] child started as pid15534
distccd[15534] setting safeguard: _DISTCC_SAFEGUARD=1
distccd[15531] cc child 15534 terminated with status 0
distccd[15531] cc times: user 0.000000s, system 0.003904s, 42 minflt, 0 majflt
distccd[15531] send DONE00000001
distccd[15531] send STAT00000000
distccd[15531] send 0 byte file /tmp/distcc_8a1a29dd.stderr with token SERR
distccd[15531] send SERR00000000
distccd[15531] send 0 byte file /tmp/distcc_866929dd.stdout with token SOUT
distccd[15531] send SOUT00000000
distccd[15531] send 0 byte file /tmp/distccd_573929dd.o with token DOTO
distccd[15531] send DOTO00000000
distccd[15531] cxx on localhost completed ok
distccd[15531] job complete
distccd[15531] deleted 4 temporary files
distccd[15531] connection from

Can someone help me?
Does someone has binaries for Tru64 4.0 ?


More information about the distcc mailing list