[distcc] newbie: problem with distcc and intel C++ 7.1: 0byteobject

Martin Pool mbp at samba.org
Wed Jun 11 07:28:21 GMT 2003

(Please reply to the list so that other people can participate)

On 11 Jun 2003, Markus Werle <numerical.simulation at web.de> wrote:
> Martin Pool wrote:

> > > configure  CXX="distcc icc" CPPFLAGS="-xc++"
> >
> > Wouldn't CFLAGS be better?
> I tried both, CPPFLAGS and CXXFLAGS, and both worked
> (well at least we came a step further)

I think CXXFLAGS is a little better, because I think this is really a
compiler option not a preprocessor option, but it's not a big deal.

> > > Is there a way to ask distcc to not delete the *.ii files?
> >
> > export DISTCC_SAVE_TEMPS=1
> >
> > on both the client and server.
> ... has exactly no effect.
> At least I could not find any *.ii file in local directory, nor
> was there any file left in /tmp/distcc*

I'm pretty sure that works in 2.5.1.  Perhaps you were setting it in a
place where it wasn't exported to the client?

Make sure that ccache is not caching the compilations.

Here is an example of me using it.  I am using HEAD so the filenames
are a little different but the relevant code has not changed.

$ rm /tmp/distcc_vexed_1001/* -r
$ ls -l /tmp/distcc_vexed_1001/
total 0
$ ./distcc -c ./cases/hello.c
$ ls -l /tmp/distcc_vexed_1001/
total 24
-rw-r--r--    1 mbp      mbp         17319 Jun 11 17:24 cppout_3708.i
-rw-------    1 mbp      mbp             0 Jun 11 17:24 lock_cpu_tcp_nevada_3632_0
drwxr-xr-x    2 mbp      mbp          4096 Jun 11 17:24 state


More information about the distcc mailing list