[ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache [SOLVED]

Christer Edwards christer.edwards at gmail.com
Wed May 12 14:27:06 MDT 2010

On Wed, May 12, 2010 at 12:25 AM, Joel Rosdahl <joel at rosdahl.net> wrote:
> Just to make it clear: The build works without ccache, right?

It has always worked without ccache, yes.

I have solved the issue now. It was on my end. Generally when I
install FreeBSD I select the 'minimal' option and nothing more. Today,
in testing this, I looked more closely at what I could/should be
installing. One of the possible items is the '32bit runtime
compatibility libraries'. After ensuring this was installed I tried my
builds again. I have now successfully completed three builds and
recorded their results. I don't understand why the inclusion/exclusion
of this would cause the difference when building with ccache, but it
does work now. Below are the speed improvements (first pass, second
pass), using ccache 3.0pre1 on FreeBSD 8.0. 4cpu, 4G RAM:

>>> World build completed on Wed May 12 12:04:26 MDT 2010
real    44m2.754s
user    80m5.733s
sys     55m59.135s
>>> Kernel build for MOUZONE completed on Wed May 12 12:19:54 MDT 2010
real    13m31.544s
user    18m38.484s
sys     11m38.547s
>>> World build completed on Wed May 12 12:41:39 MDT 2010
real    7m0.725s
user    10m1.925s
sys     9m56.014s
>>> Kernel build for MOUZONE completed on Wed May 12 12:44:00 MDT 2010
real    1m34.594s
user    1m1.464s
sys     0m57.740s

(after two passes)
[root at mouzone /usr/src]# ccache -s
cache directory                     /usr/.ccache
cache hit (direct)                  1890
cache hit (preprocessed)             652
cache miss                         27492
called for link                      918
multiple source files                  2
compile failed                       300
preprocessor error                   111
bad compiler arguments                37
not a C/C++ file                    2284
autoconf compile/link               1547
unsupported compiler option            4
no input file                        182
files in cache                     27492
cache size                         407.3 Mbytes
max cache size                       1.0 Gbytes

Thank you for your help.

Christer Edwards

More information about the ccache mailing list