Difficulties to install,Info needed..

Jarmo Kettunen oh1mrr at nic.fi
Tue Apr 16 21:49:33 EST 2002


Just have tried to get my wlan working in Mandrake 8.2 and have
difficulties a lot.

I have Orinoco-silver-card TI-1225 cardbus adapter.
Mandrake installation failed when started to look PCMCIA...it just
hung that point,after two beebs,I suppose was indigation of found card.

Ok.Took adapter and card away,installation went like in western movies,
without any whisky and dead indians...;-)

Installed adapter and card and had to struggle long time,when got it working
.Had to compile kernel without pcmcia and drivers.

Installed pcmcia-cs-3.1.30 and newest drivers from orinocowireless.com.
Ok...working,but can't use forinstance wireles-tools,nor orinoco_cs...

I tried this with pcmcia-cs-3.1.33 but that fails in compile stage.

I have now tried with 3 kernels also,mdk's 2.4.18,2.4.18 from kernel.org
and 2.4.19-pre6...Same results....

Now if I compile kernel with pcmcia and start computer I get:
Linux Kernel Card Services 3.1.22
options [pci] [cardbus] [pm]

PCI: Found IRQ 10 for device 00:11:0
PCI: Sharing IRQ 10 with 00:11.0
PCI: Sharing IRQ 10 with 01:05.0
PCI: Found IRQ 10 for device 01:05.0
PCI: Found IRQ 10 for device 00.11.1
PCI: Sharing IRQ 10 with device 01:05.0
PCI: Sharing IRQ 10 with device 00:11.1

md: md driver 0.90.0 MAX_MD_DEVS=256 MD_SB_DISKS=27

yenta irq list 0000,pci IRQ 10
socket status 30000010
yenta irq list 0000,pci IRQ 10
socket status 30000010

md: Autodetecting Raid arrays
md: autorun......
md: ....autorun DONE

IEEE 802.2 LLC for Linux 2.1 (c) 1996 Tim Alpaerts

NET4: Linux TCP/IP 1.0 for Net4.0
IP Protocols: ICMP,UDP,TCP
IP: routing cache hash table of 4096 buckets 32Kbytes ..32768 bind
NET4: UNIX domain sockets 1.0/smp for Linux Net 4.0
cs: socket dfe96000 timed out during reset,try increasing setup_delay
spurious 8259A interrupt: IRQ 7
And here it hangs.....

(yes,have tried to increase setup_delay,no change)

I have here PCMCIA/CARBUS support compiled in,if I compile it as
module,adapter/card is not detected....

Is it so,that these kernels,what I've used doesn't work with my equipments
ie.Is this TI-1225 adapter some kind of !"##!@ win thing?

If someone kindly could make my day,by showing me right direction
to remove this problem.


Ps.This message contains many typos,because of not natural born
english writer...

More information about the wireless mailing list