SMC 2632 (PLX) Ad-hoc mode fails

Thomas Leineweber thomas at
Mon Apr 8 23:23:30 EST 2002


since two weeks, I'm trying to get two (PLX-based) SMC2632 cards to talk
with each other in Ad-hoc mode. I have tried different versions of the
orinoco-driver with no success. Here are some diagnostics made with
version 0.11:

After loading the driver, on both sides the following commands are
  iwconfig eth0 essid OM79
  iwconfig eth0 mode Ad-hoc

According to the manual of the cards, the light should be blinking when
the card is set to Ad-hoc mode, but if I set up the second card while
the first card is in Ad-hoc mode, the light is on permanently.

iwconfig gives the following on the first card:
eth0      IEEE 802.11-DS  ESSID:"OM79"  Nickname:"Prism  I"
          Mode:Ad-Hoc  Frequency:2.462GHz  Cell: 00:00:00:00:00:00
	  Bit Rate:2Mb/s   Tx-Power=15 dBm   Sensitivity:1/3  
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

on the second card it gives the same, but the Cell field is not null.

Here are the messages given during the initialisation of the second
card (slightly edited):

hermes.c: 5 Apr 2002 David Gibson <hermes at>
orinoco.c 0.11 (David Gibson <hermes at> and others)
orinoco_plx.c 0.11 (Daniel Barlow <dan at>)
PCI: Enabling device 00:0f.0 (0100 -> 0103)
PCI: Found IRQ 3 for device 00:0f.0
orinoco_plx: CIS:
orinoco_plx: Local Interrupt already enabled
Detected Orinoco/Prism2 PLX device at 00:0f.0 irq:3, io addr:0xfc00
eth0: Station identity 001f:0003:0000:0008
eth0: Looks like an Intersil firmware version 0.08
eth0: Ad-hoc demo mode supported
eth0: IEEE standard IBSS ad-hoc mode supported
eth0: WEP supported, 104-bit key
eth0: MAC address 00:04:E2:29:5F:59
eth0: Station name "Prism  I"
eth0: ready

I also tried to interchange the two iwconfig commands, but then it said,
that this firmware needs an essid to work in Ad-hoc mode.

Has someone yet made this card to work in Ad-hoc mode?

Thomas Leineweber

More information about the wireless mailing list