ORiNOCO/Linux-Mandrake nightmare - for the love of God, please help me

David Boettger boettger at hknet.com
Fri Oct 5 02:13:09 EST 2001


I'm having an incredibly strange problem with my ORiNOCO/Linux setup.
I've spent over a week on this problem and I'm at the limit of my
(admittedly limited) knowledge. Frankly, I don't know if this is an
orinoco_cs problem or not, but I don't know how to rule it out yet.

Here's the setup:

Fujitsu Lifebook C-6556
Lucent ORiNOCO silver card
Lucent ORiNOCO RG-1000 access point in gateway (NAT) mode
Linux-Mandrake 8.0 (kernel PCMCIA disabled)
PCMCIA-CS 3.1.29 (latest)
orinoco_cs (whatever comes with 3.1.29 of PCMCIA-CS)
Wireless Tools 20 (latest)
DHCP via dhcpcd

The problem I'm having is as follows. PCMCIA-CS compiles and installs
beautifully. I'm 99% sure I've configured /etc/pcmcia/wireless.opts and
/etc/pcmcia/config properly because I get no errors during boot (or in
syslog or boot.log), plus I get two high beeps. /proc/wireless/net is
also updated with RF measurements in real-time, meaning the card has
associated with the AP. Further ifconfig's output looks fine (IP
address/net mask/broadcast address assigned) and iwconfig's output looks
fine (ESSID/encryption key okay).

Now, the first problem is that it takes 40+ seconds to get the DHCP
grant during boot. I've done some test using Ethereal (post-boot) and
I'm sure what's happening is that the Linux box is trying to do a DNS
lookup on its OWN IP address, e.g., I have no
idea why it's doing this or how to stop it. This happens again if I do
"ifdown eth0; ifup eth0".

Second, I can ping the AP (, and I can dig an Internet host
(dig google.com), and I can ping an Internet host by IP address (ping, but - here's the pisser - "ping google.com" times out.
Ethereal shows that the DNS lookup on google.com IS working, but then
the Linux box is sending an ICMP "destination unreachable (port
unreacheable)" message back to the DNS server and then giving up!
Naturally, I can't do anything given this: web browsing, e-mail,
everything is broken.

I've checked everything I can think of, such as:

o Diabling the firewall (bastille-firewall)
o Disabling every other service that isn't absolutely critical
o "arp -a -n" shows what I would expect
o "route" shows what I would expect
o I've tried pump as well as dhcpcd. I've also tried static IP
addresses. No joy.

Other tidbits:

o Everything works fine in Windoze
o Everything works fine in Linux IF I set the RG-1000 in
bridge/infrastructure mode and use a PPPoE client from the laptop. (I do
NOT want to do this; I need to share the Internet connection in

I have no idea what to do next. If I spend any more time on this problem
my girfriend is going to dump me.

Please help.

David Boettger

More information about the wireless mailing list