Mount point permissions

Nikki at
Wed Nov 30 21:01:57 GMT 2005

I'm having the identical issue.  Wasn't able to find whether you had ever
gotten a response or not?  Any luck on a sol'n?


I am trying to mount a windows share using the following command:
mount -t smbfs //server/share /mount/point -o credentials=passfile

This works. However, I need the share to be readable and writable by all
users on the Linux machine. That means /mount/point needs to be mounted
as 777. It mounts as 755. The initial permissions on /mount/point are
777 before mounting, but change to 755 after mounting.

I have tried other options without success:

dmask=0000 (not relevant, but tried anyway)
umask=0000 (also tried anyway)

The windows computer is Windows 2000 ntfs. The folder share is readable
and writable with full control to everyone. The credentials file
contains the username and passwd of the Windows administrator.

Am I missing something simple or can Samba not mount a Windows 2000
share as 777 writable to all?



1500 years ago, everybody knew the Earth was the centre of the Universe.
500 years ago, everybody knew the Earth was flat.
15 minutes ago, you knew that people were alone on this planet.
Imagine what you'll know tomorrow.
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the smb-clients mailing list