Files and folders missing in windows share accessed with smbmount

Denis Poisson denisp at
Fri Aug 27 21:04:42 GMT 2004

When I mount a Windows share containing many files and folders with smbmount
on Linux, not all the files/folders are accessible from the Linux machine.
For example, I have a subfolder of a mounted share that contains exactly
1421 items (files and folders).  If I get a listing of this folder from the
Linux machine, it will rarely show all of the 1421 items.  In fact it
doesn't always show the same number of items; sometimes it will show 699
items, 700, 1215, 1216, etc.  I have tried with a RedHat7.1, kernel 2.4.25
machine with samba-2.0.10-5.7.1 and then upgraded to samba-3.0.5 and tried
again.  I have also tried with a debian 3.0 kernel 2.4.26 machine with samba
2.2.3a-13.  The problem was the same in every situation.  I have checked the
permissions on the files in the windows share and the user connecting with
smbmount has at least read and execute on everything.

I use smbmount as follows to mount the windows share:

smbmount "\\\\machine\\share" /mnt/ -o username=user,password=passwd

The windows share does get mounted but there seems to be a problem when a
mounted subfolder contains a large number of files/folders

Note that I am not using the samba server on the linux machines.  Only
smbmount and smbumount to access Windows shares.

Am I missing something?

Denis Poisson

More information about the smb-clients mailing list